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# $ K 
Application Purpose 
 
ScanMagic is a software application for the visualization, analysis and processing of 
remote sensing data. In most of the cases, ScanMagic makes it possible to carry out a 
complete range of activities on preparation of Earth remote sensing output products 
without application of additional software tools. 
 
ScanMagic is a MDI application for Microsoft Windows 98/2000 environment. It features 
a modern and intuitive graphical user interface easy to understand and use. ScanMagic 
provides the following main operations with the images: 
 
-   displaying images with an arbitrary colour synthesis, contrasting and scaling; 
-   geographical location of the images, including gelocation by satellite orbital elements; 

cartographic location of the images; geocorrection by implementing adjustments for 
satellite orbital position and attitude; geocorrection with usage of ground control 
points; �image-to-map� and �image-to-image� georeferencing; 

-   import and overlay of digital maps on the images; 
-   image transformation to map projections; mosaicking; 
-   export of original and mapped images to generic graphical formats and GIS formats; 
-   image printing. 
 
ScanMagic is built with the use of modern effective techniques of image processing. 
Along with other provisions, the software is capable to analysis the images up to 4 Gb in 
real time of viewing, to implement images reprojection �on-the-fly�, to repeatedly correct 
and visually evaluate the quality of images without consumption of considerable time 
with the actual data processing only at the final stage. 
 
All comments, remarks and evaluation of ScanMagic Application are requested to be 
forwarded at support@scanex.ru indicating �ScanMagic� in the letter subject field. 
 

mailto:support@scanex.ru
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# $ K 
Requirements to Hardware 
 
-   Windows 98, 2000 operation system or later versions. 
-   Pentium III processor or higher.    
-   RAM is not less than 256 Mb. One has to note, that free RAM is important for the 

Application operation speed. Free RAM size should be more than size of the image 
converted to cartographic projection. In a case of mosaicking, RAM size should be 
not less than total size of all source images. 

-   Disc free space is not of particular importance; but it should be within reasonable 
limits � not less than a few hundreds of Mb. If possible, it is recommended that more 
fast hard discs should be used. 

-   Monitor graphic mode - TrueColor (32 bit/pixel). Screen size should be not less than 
1024x768 pixels. 
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# $ K 
Application Composition 
 
ScanMagic Application consists of the basic module (ScanMagic.exe), selection of 
dynamic libraries (hd413m.dll, hm413m.dll, gdal11.dll, proj.dll and sophocl.dll) and 
configuration file (ScanMagic.ini), which contains current settings and may be absent in 
a general case. The Application also includes Help (ScanMagic.hlp and ScanMagic.cnt 
files) and the Present User�s Manual (ScanMagic.pdf). Besides, the Application may 
include some additional data, such as digital maps, file formats description, etc. 
 
 
The Application is supplied as an installation version. 
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# $ K 
Image Import 
 
ScanMagic presently implements import and processing of the data with radiometric 
resolution up to 16 bit/pixel received from the following satellites: IRS-1C, IRS-1D, 
TERRA, RESURS 01-№3, RESURS 01-№4, METEOR-3M and NOAA 12-17: 
 
Satellite Sensor Product Format 

LISSL0, PANL0, SCANEX IRL/IRPIRS-1C/1D LISS-VNIR, 
LISS-SWIR, 
WIFS, 
PAN 

LISS1A, PAN1A, 
LISS1B, PAN1B 

HDF 

TERRA MODIS MOD02/250, 
MOD02/500, 
MOD02/1KM 

HDF 

RESURS O1-№3/№4 MSU-E Level 0 SCANEX RSR 
METEOR-3M MSU-E Level 0 SCANEX RSR 
NOAA 12-17 HRPT Level 0 SCANEX HRP 

 
Besides, ScanMagic allows to import and processing of the images of series generic 
graphic and GIS formats: BMP, TIFF/GeoTIFF, GIF, JPEG, PNG, PGM/PPM, ERDAS 
IMG, ESRI BIL/BIP/BSQ, ENVI BIL/BIP/BSQ, CEOS SAR, USGS DEM, etc. 
 
An image of one of the formats described above can be opened through the menu 
command File -> Open… or  button of the Application toolbar. In the process a 
standard dialog box for opening file appears (Figure 1). It is necessary to select one or 
several files and click the Open button. 
 

 
 

Figure 1. 
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The ImageManager dialog panel (Figure 2) makes it possible to open images.  For 
displaying the ImageManager dialog panel, select View -> Image Manager … menu 
command or click  button on the Application toolbar. The panel is created in a docked 
bar style, it is attached to the top or to the bottom border of the Application main 
window. To change position of panel, click  button placed in upper left corner of Image 
Manager panel. 
 

 
 

Figure 2. 
 

To view the list of images from a directory, first enter the path to the directory in Folder 
edit box of Image Manager dialog panel, then click Refresh button. Images directory 
may be selected by clicking the respective Browse� button. Images with some basic 
parameters from the current directory are displayed as a list. 
 
While Image Manager dialog panel and Region window being open, all geolocated 
images of the list are automatically reflected in the Region in a current cartographic 
projection as boundaries delineations. Images marked on the list are also marked with 
another color in the Region. 
 
If the Region is created with Image Manager being open (for example, by clicking  
button on the Application toolbar), it will automatically occupy the size of the whole 
world in Equidistant Cylindrical projection. Region is created automatically in first 
opening Image Manager panel. A range of world vector maps, which are overlaid on 
such a Region by default, is set in Default world map edit box on Paths tab of Options 



 ScanMagic v.1.5  

 Copyright © 2002 RDC ScanEx Page 8 of 30  
 

settings dialog box of the Application. To display the settings dialog box, select File -> 
Options… menu command or click  button of the Application toolbar. 
 
Image Manager panel can open one or several images. To do so, first mark required 
images on the list, then press the right mouse button and select Open command in the 
appeared contextual menu. For deleting of one or several files from the directory, first 
mark respective row of the list, then press the right mouse button and select Delete 
command in the appeared contextual menu. 
 
Images may be opened or deleted directly from the Region window, if its boundaries are 
reflected therein. To do it, click the right mouse button near the boundaries of a required 
image in the Region window. The boundaries of a marked image will change the color, 
and a respective row in the list of Image Manager panel will become active. Use Open 
command of the contextual menu to open the image. Use Delete command to delete 
the image. 
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# $ K 
Obtaining Information about Image 
 
The Application provides for the following: 
 
-   obtain general information about the image (file format, satellite name, sensor name, 

orbit number, beginning and end time for taking images, image size, number of 
channels, etc.); 

-   control parameters of the marked fragment (width, height and size); 
-   measure colour characteristics of image pixels in real-time along with the cursor 

movement; 
-   measure planar,  geographic and map coordinates of image pixels in real-time along 

with the cursor movement. 
 
Image characteristics are displayed in Info tab of Image Properties dialog panel 
(Figure 3). To display the tab, first open Image Properties dialog panel through the View 
-> Image Properties… menu command or by clicking  button on the Application 
toolbar. The panel is created in a docked bar style, it is attached to the left or to the right 
border of the Application main window. To change panel position, click  button placed 
in upper left corner of Image Properties dialog panel. 
 

 
 

Figure 3. 
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# $ K 
Image View Control 
 
The Application provides for the following: 
 
-   displaying images in Grayscale mode with arbitrary selection of a channel and 

synthesis of colour RGB image with arbitrary set of channels; 
-   viewing and channel-by-channel histogram processing of the image visible part for 

ranges 0..255 (8 bit/pixel) and 0..65535 (16 bit/pixel); manual and automatic 
contrasting of the image histogram, equalizing; 

-   arbitrary image scroll and zoom in a view window: Zoom In, Zoom Out, Zoom To 
Width, Zoom To Height, Actual Zoom (1:1), Zoom To Region, Drag The Display, 
Previous Zoom, etc. 

 
A few viewing windows for some image may be created at one time for displaying with 
specific settings for colour synthesis, zoom and contrasting. 
 
Control of view mode, synthesis, histogram and processing algorithm is performed in 
View tab of Image Properties dialog panel (Figure 4). 
 

 
 

Figure 4. 
 
The Grayscale group of elements in View tab of Image Properties dialog panel makes it 
possible to select an arbitrary image band for viewing in the Grayscale mode. 
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The Colour group of elements in View tab of Image Properties dialog panel makes it 
possible to select three arbitrary image bands for synthesis of the RGB image. 
 
Controls , ,  indicate, for which channel of synthesised RGB image the 
histogram is displayed in View tab of Image Properties dialog panel. 
 
One has to note, that the histogram is created for only that part of the image, which is 
currently being viewed in the view window. A histogram is built up at the moment of 
drawing the image in the viewing window. Signalling element of the status bar looks like 

, at the moment of the image drawing, and it looks like  upon drawing completion. 
 
The boundaries of the linear contrasting range are established with the help of  

  controls. Minimum and maximum boundaries of the linear 
contrasting range may also be set by clicking left or right mouth button with the cursor 
being on the histogram.  
 

Button   of View tab of Image Properties dialog panel is intended for setting the 
linear contrasting function for the whole range of the current channel of RGB image. 
 

Button  of View tab of Image Properties dialog panel makes it possible to perform 
the equalizing of the current histogram in the current range. 
 

Button  of View tab of Image Properties dialog panel makes it possible to perform 
quick contrasting of the image visible part. In the process the boundaries of the 
contrasting range are automatically determined with cutting some percentage of the 

histogram area along the edges. This percentage is set in   control. 
 
Fast contrast option is accessible through Image -> Easy Contrast menu command and 

 button of the Application toolbar. 
 
Image zoom control can be exercised via Image menu item (commands: Previous 
Zoom, Zoom In, Zoom Out, Zoom To Region, Zoom To Width, Zoom To Height, Actual 
Zoom) or by using elements   of the Application toolbar. 
 
To move a displayed part of the image in the window it is possible via scrollbars or 
through  button of the Application toolbar (Image -> Drag The Display menu 
command). 
 
Location of windows can be controlled via Window menu item (commands: Cascade, 
Tile Horizontally, Tile Vertically, Arrange Icons) or by using elements  of the 
Application toolbar. 
 
A new window can be added to the opened image by Window -> New Window menu 
command or by clicking  button on the Application toolbar. 
 
The Algorithm elements group in View tab of Image Properties dialog panel allows us to 
display the image with account of some processing algorithm. For example, it is 
possible to eliminate the distortion on the left and right edges of MOD02/250, 
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MOD02/500 and MOD02/1KM products, which are the outcome of MODIS sensor 
design peculiar features, to compensate the shift of CCD2 respective CCD1 and CCD3 
for Level-0 data of IRS-1C and IRS-1D satellites PAN sensor, etc. 
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# $ K 

Image Geographical Location 
 
-   The Application provides for automatic geographical and map location of imported 

images, as well as manual location as per �image to map� and �image to image� 
techniques 

 
-   Among other methods, one may use trajectory data from  NORAD TLE format 

messages for images geolocation; and geocorrection may be done by selecting 
adjustments for satellite orbital position and attitude angles thereof. 

 
-   For more precise geolocation of the image in converting it into cartographic 

projections ground control points are used. They are determined by the User 
manually, in particular, with the help of vector maps as a geographical basis. 

 
It is possible to determine, whether the image is geolocated, by the icon of the image 
window. If it looks like , the image is geolocated, if the window icon looks like , the 
image is not geolocated. 
 
Precision of geolocation can be visually controlled by overlaying the vector map on the 
image. 
 
It is necessary to renew image geolocation after the change of adjustments in the 
process of geolocation correction (location of the vector maps overlaid on the image will 
be changed as well). It can be done by File -> Refresh Geolocation menu command or 
with the help of   button of the Application toolbar. A similar button is also available in 
Geo tab of the Image Properties dialog panel. 
 
In general, imported images can have three modes of location: 
1. Simple Image � general raster. 
2. Mapped Image � cartographically located image, whose each pixel�s map 

coordinates X, Y can be changed based on WORLD location from the file heading 
(ULX, ULY, XDIM, YDIM). If the image heading contains parameters of map 
projection, geographical coordinates can be measured for each pixel. 

3. Geolocated Image � geolocated image, whose each pixel�s geographical latitude and 
altitude can be changed. Geolocation is made based on the orbital elements from the 
file heading, latitude and altitude grid from the file heading, trajectory data from 
outside NORAD messages, etc. 

 
During conversion to the Region, the image in Simple Image mode does not contain 
geo or map location, and it is initially placed �as it is� with  left � top  levelling position. 
Such image location can be done by �image to map� and �image to image� techniques. 
 
During conversion to the Region, the image in Mapped Image mode is immediately 
placed taking into account its own map location. If image map parameters differ from 
Region map parameters, the image is automatically reprojected. If the image only 
contains WORLD location (map projection is not clearly determined), one has to 
established a required map projection for the Region. If necessary, location correction is 
made based on ground control points. 
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During conversion to the Region, the image in Geolocated Image mode is  placed 
therein taking into account its own geolocation. If necessary, fine correction of location 
is made based on ground control points. 
 
Geolocation control is performed in Geo tab of Image Properties dialog panel (Figure 5). 
 

 
 

Figure 5. 
 
The current mode of image location is established with the help of �SIMPLE IMAGE�, 
�MAPPED IMAGE� and �GEOLOCATED  IMAGE� control elements. 
 
The appearance of control elements in Geo tab is changed while changing a location 
mode. Given below is a description of operation with Geo tab control elements in 
selecting Geolocated Image mode (this mode is not available for all imported formats). 
 
If �Use orbit parameters from the image file� option is selected, image geolocation will 
be calculated based on satellite orbital elements and attitude parameters from the file 
header. This option is not available, if orbital elements are missing in the image file. 
 
If �Use orbit parameters from the TLE file� option is selected, image geolocation will be 
calculated based on orbital elements from the outside file (attitude parameters from the 
file header are not used, but they are available for viewing). The full path to the file 
containing NORAD TLE messages is selected in a corresponding field of the group. It is 
permissible to select files mask, for example, �D:\NORAD\*.tle�. In this case, that 
message will be automatically selected, which exactly fits the time of receiving the 
image. It is possible to establish the shift of the required message in  days since the 
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moment of taking the picture with the help of  
control element. 
 
Controls Time adding, Roll adding, Pitch adding and Yaw adding helps to set 
adjustments of the satellite orbital position and angles of its orientation. One has to 

remember, that after setting new options and geolocation parameters, button  should 
be clicked. 

To save current geolocation parameters into image file, click  button. 
 
The Application supports the selection of ground control points for each image, makes it 
possible to edit ground control points, to perform their on-line determination by the 
image. 
 
Ground control points control is performed in GCP tab of Image Properties dialog panel 
(Figure 6). 
 

 
 

Figure 6. 
 
The editor of ground control points consists of the ground control points list and a group 
of elements, where parameters of the selected ground control point are displayed. 
 
For on-line picking up a ground control point by the image and the map overlaid on it, 
select the mode of ground control points picking-up by clicking Pick Up button. Then 
move the mouse cursor to the image object and click left button, afterwards similarly 
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click the element identical to the image object on the vector map (the map should be 
overlaid on the image). 
 
For input of the ground control point coordinates manually, click Create button. A new 
ground control point shall be added to the list. Select this ground control point from the 
list and change its coordinates in respective fields, then click Apply button. 
 
For viewing the ground control point position, select it from the list and click View button, 
or simply double-click the ground control point on the list. The ground control point 
position is drawn in yellow in the image window. Click the empty recording in the list of 
ground control points to cancel the drawing of the ground control point position. Click 
View All button to view all ground control points positions. 
 
Click Remove All button to remove all ground control points from the list. To remove one 
ground control point select it from the list and click Remove button. 
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# $ K 
Operation with Vector Maps 
 
The Application provides for the following: 
 
-   overlaying of up to one hundred layers of the vector digital maps in ShapeFile GIS 

ArcInfo format (support of polygonal, polylinear and point objects); 
-   overlaying of vector maps both on the source image and on the image converted into 

the cartographic projection; 
-   change of vector layers draw parameters during displaying. 
 
Map control is performed in Map tab of Image Properties dialog panel (Figure 7). 
 

 
 

Figure 7. 
 
To add vector maps, click  button of Map tab of Image Properties dialog panel. Select 
imported files of ShapeFile GIS ArcInfo format in the appeared dialog box and click 
Open button. One may also use Image -> Add Vector Layers… menu command or   
button of the Application toolbar. 
 
To delete all vector maps from the image, click   button of Map tab of Image 
Properties dialog panel. This command is also available through Image -> Remove All 
Vector Layers menu command or  button. 
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To delete one or several maps from the list of current image vector layers, mark 
respective entries of the list, click right mouse button thereon and select Remove 
command on the appeared contextual menu. 
 
To enable or disable the displaying of some layer, establish or remove a flag on the list 
of layers. The same actions may be performed by marking required entries of the list by 
clicking right mouse button thereon and selecting Visible or Invisible commands on the 
appeared menu. 
 
To change the size of vector objects of some layer, select a required value in Size 
column for a respective entry of maps list in Map tab of Image Properties dialog panel. 
 
To change the color of a vector layer drawing, double-click left mouse button in Color 
column for a respective entry of maps list and select a required color in the appeared 
dialog box. One may establish a display color simultaneously for some set of layers by 
marking required entries of the list by clicking the right mouse button thereon and 
selecting Color command  in the appeared contextual menu. 
 
If parameters of the image geolocation are changed with the help of  button,  the 
position of the vector maps shall be recalculated automatically. 
 
If a fragment is marked on the image, the vector maps shall only be overlaid within the 
limits of the fragment. To overlay the maps on the whole image, temporarily switch off 
the mode of fragment marking . 
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Conversion to Cartographic Projections 
 
ScanMagic makes it possible to transform single images or their fragments to 
cartographic projections �on-the-fly�, as well as to create photometricly levelled mosaics 
of images from different sensors for a certain geographical region with an arbitrary 
integration of different channels data and spatial resolutions. 
 
Current software version supports more than 70 cartographic projections: 
 
-   Albers Equal Area 
-   Azimuthal Equidistant 
-   Behrmann 
-   Bonne 
-   Cassini 
-   Central Cylindrical 
-   Collignon 
-   Craster Parabolic (Putnins P4) 
-   Eckert I 
-   Eckert II 
-   Eckert III 
-   Eckert IV 
-   Eckert V 
-   Eckert VI 
-   Equal Area Cylindrical 
-   Equidistant Conic 
-   Equidistant Cylindrical 
-   Fahey 
-   Foucaut 
-   Foucaut Sinusoidal 
-   Gall (Gall Stereographic) 
-   Gall�s Orthographic (Peters) 
-   Gauss-Kruger 
-   Gauss-Kruger (6 deg. zone) 
-   Gnomonic 
-   Hatano Asymmetrical Equal Area 
-   Kavraisky V 
-   Kavraisky VII 
-   Lambert Azimuthal Equal Area 
-   Lambert Conformal Conic 
-   Lambert Equal Area Conic 
-   McBride-Thomas Flat-Polar Parabolic 
-   McBryde-Thomas Flat-Polar Quartic 
-   McBryde-Thomas Flat-Polar Sine (No. 1) 
-   McBryde-Thomas Flat-Polar Sinusoidal 
-   McBryde-Thomas Flat-Pole Sine (No. 2) 
-   Mercator 
-   Miller Cylindrical 
-   Mollweide 
-   Nell-Hammer 
-   Orthographic 
-   Perspective Conic 

-   Plate Caree 
-   Polar Stereographic 
-   Polyconic (American) 
-   Putnins P1 
-   Putnins P2 
-   Putnins P3 
-   Putnins P3' 
-   Putnins P4' 
-   Putnins P5 
-   Putnins P5' 
-   Putnins P6 
-   Putnins P6' 
-   Quartic Authalic 
-   Robinson 
-   Sinusoidal (Sanson-Flamsteed) 
-   Stereographic 
-   Transverse Cylindrical Equal Area 
-   Transverse Mercator 
-   Universal Transverse Mercator (UTM) 
-   van der Grinten (I) 
-   Wagner I (Kavraisky VI) 
-   Wagner II 
-   Wagner III 
-   Wagner IV (Putnins P2') 
-   Wagner V 
-   Wagner VI (Putnins P1') 
-   Werenskiold I 
-   Werner 
-   Winkel I 
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ScanMagic supports user-defined ellipsoids and more than 40 standard ellipsoids: 
 
-   MERIT 1983 
-   Soviet Geodetic System 85 
-   GRS 1980 (IUGG,1980) 
-   IAU 1976 
-   Airy 1830 
-   Appl. Physics. 1965 
-   Naval Weapons Lab.,1965 
-   Modified Airy 
-   Andrae 1876 (Den.,Iclnd.) 
-   Australian Natl & S. Amer. 1969 
-   GRS 67 (IUGG 1967) 
-   Bessel 1841 
-   Bessel 1841 (Namibia) 
-   Clarke 1866 
-   Clarke 1880 mod. 
-   Comm. des Poids et Mesures 1799 
-   Delambre 1810 (Belgium) 
-   Engelis 1985 
-   Everest 1830 
-   Everest 1948 
-   Everest 1956 

-   Everest 1969 
-   Everest (Sabah & Sarawak) 
-   Fischer (Mercury Datum) 1960 
-   Modified Fischer 1960 
-   Fischer 1968 
-   Helmert 1906 
-   Hough 
-   International 1909 (Hayford) 
-   Krassovsky,1942 
-   Kaula 1961 
-   Lerch 1979 
-   Maupertius 1738 
-   New International 1967 
-   Plessis 1817 (France) 
-   Southeast Asia 
-   Walbeck 
-   WGS 60 
-   WGS 66 
-   WGS 72 
-   WGS 84 
-   Normal Sphere (r=6370997) 

 
ScanMagic Application makes it possible to import, display and analyse images of a 
large size (no limitations are imposed on the image input file). Image conversion into 
cartographic projections is performed �on-the-fly� along with viewing. All source images 
(or their fragments) in the process of conversion to map projection boot into the RAM. 
 
The present version of the Application realizes the technology of creation of so called 
Region with a possibility to change its characteristics on-line. In a general case, Region 
is an image of some area of the earth surface in one of the cartographic projections. 
Region's raster is synthesised as a result of spatial and spectral mounting of several 
images obtained at different time from different sensors. 
 
To convert one or several images into a cartographic projection, one has to select File -
> Create Region… menu command or to click  button of the toolbar. As a result a 
new empty �Region� window will appear in the Application. Then it is necessary to select 
characteristics of the created raster and parameters of the cartographic projection in 
Region tab of Image Properties dialog panel and to click Apply button (Figures 8,9). 
 
Control of Region characteristics is exercised by the elements of Region tab of Image 
Properties dialog panel. After changing Region's main characteristics, it is necessary to 
click Apply button to redraw Region�s raster in the view window. For example, the 
following refer to these characteristics: number of raster�s channels, list of images to be 
converted, geographic borders of the Region and cartographic projection parameters. 
However, in case of changing some properties, redrawing of the Region takes place in 
the View window at once. For example, it is not necessary to click Apply button of 
Region tab of Image Properties dialog panel in case of changing background color, 
order of arrangement and type of pictures interpolation, parameters of some pictures 
contrasting, etc. 
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Below is a description of parameters, whose application for the Region requires clicking 
Apply button. 
 
Channel NN element of  Region tab of Image Properties dialog panel is used for setting 
the number of Region's channels. 
 
Bits per pixel of the image is set automatically taking into account maximal radiometric 
resolution of the pictures used for creating the Region. 
 
Width, Height и Size (Mb) elements show calculated dimensions of synthesised raster 
at the current Region's parameters. 
 
Image sub-tab provides selection of the list of images converted into the Region and 
parameters of their conversions (Figure 8). 
 

 
 

Figure 8. 
 

List of Available Images of Image sub-tab contains images available for conversion into 
cartographic projection. It includes all images geographically located and opened by 
ScanMagic Application. 
 
List of Selected Images of Image sub-tab contains images selected by the user for 
conversion into Region's cartographic projection. Images of the list may be added and 
deleted by  buttons. 
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Output channels elements are used for establishing the order of arrangement of 
spectral channels in the Region for the image selected in Selected Images list. None 
indicates that no spectral channels of the current image will be placed in the present 
channel of the Region. 
 
Projection sub-tab provides setting parameters of the Region cartographic projection 
(Figure 9). 
 

 
 

Figure 9. 
 
Border autodetection option indicates, that all geographic borders will be selected 
automatically so, that all converted images could be accommodated in the Region (i.e. 
images on the list of Selected Images of Image sub-tab). 
 
Geographic borders may be set manually with the help of Border group of elements 
after activating the option of the same name. 
 
After clicking  button and selecting Autodetect item in the appeared contextual menu 
one may fill the fields of Border group of elements with values of geographic borders 
calculated automatically. After selecting World item in the contextual menu one may fill 
the fields of Border group of elements with values describing geographic borders of the 
whole world. If the image of the Region has already been created, and it is necessary to 
reduce its geographic borders, it may be easily done by marking its fragment and 
establishing new borders with the help of Fragment item of contextual menu.  
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Resolution (meters) element establishes spatial resolution of the Region in meters. One 
has to remember, that this value is nominal, i.e. it refers, for example, to pixels of the 
image at the latitude of standard parallel of cartographic projection. 
 
Projection control element is intended for selection of cartographic projection. Other 
elements of Projection sub-tab, which are not described, are intended for setting 
parameters of selected cartographic projection. 
 
Region�s parameters, which do not require clicking  Apply button, are described below. 
 
Bckg color  element of Region tab may be used for changing the brightness of the 
background of all Region's channels. 
 

 buttons may be used for changing the order of displaying pictures of the Region. 
Upon clicking the buttons, the current image in Selected Images list moves up or down 
and respective redrawing of the Region takes place. 
 
Interpolation element of Image sub-tab may be used for changing the type (nearest 
neighbor, bilinear or bicubic) of photometric interpolation, for the image selected in 
Selected Images list. 
 
Visible element of Image sub-tab may be used for switching on and switching off the 
displaying of the image selected in Selected Images list. 
 
CCD1, CCD2, CCD3 elements provide switching on and switching off the displaying of 
separate parts of the image (for example, for PAN), and respective editing fields make it 
possible to correct a relative shift of these parts in terms of row/column of the source 
raster. 
 
This version of the Application features a possibility to control photometric and 
geometric characteristics of displayed pictures directly through the Region window, 
while working with the Region. For example, it is possible to perform photometric 
alignment of the mosaic images by selecting individual parameters of contrasting or to 
perform a precision geometric matching of the mosaic�s pictures. 
 
Access to the characteristics of the images converted into the Region is made by the 
Image control element of Image Properties dialog panel. This element makes it possible 
to select the name of analysed image from the list when working with the Region. In 
case of selecting �Region� line, the work through Image Properties panel is performed 
with all images of the Region, and if the name of one of the images used for mosaicking 
is selected, activities are only carried out with its image. 
 
For example, to perform photometric alignment of converting image, one has (with 
selected  �Region� item in Image control element) to set the linear contrasting for the 
whole range for the whole Region using elements of View tab. And then it is necessary 
to perform in turn the contrasting of individual images used for mosaicking. For this it is 
necessary to select the name of image in Image control element and to contrast its with 
help of View tab elements. Afterwards, the same should be done for  the other images. 
 
Similar actions may be taken in performing precision overlapping of the images in 
mosaic, directly working with the Region window. After selection of the name of the 
image with the help of Image control element of Image Properties dialog panel, one can 
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pick up ground control points in Geo tab correcting the geolocation using technique 
�image to map� or �image to image�. One has to remember, that after changing 
parameters of images geolocation (in particular, after picking up ground control points), 
it is necessary to click  button of the Application toolbar. 
 
During geolocation process while using �image to image� technique, it is possible to 
change the order of images arrangment quickly by using �Page Up�, �Page Down� 
buttons. In the process the image in the Region window selected as a current image 
with the help of Image control element, will move up or down in accordance with 
Selected Images list of Image sub-tab of Region tab. A representation in the Region of 
the current image can be switched on and switched off by pressing �Ins� button of the 
keyboard (similar actions are taken with the help of Visible element of Image sub-tab of 
Region tab). 
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# $ K 
Operation with Image Fragments 
 
The Application makes it possible to perform the following: 
 
-   mark the fragment on-line on input or converted image; 
-   overlay vector maps on the image within the limits of marked fragment; 
-   convert the fragment marked on the input image fragment; 
-   export the marked fragment. 
 
Any fragment may be marked by using a mouse left button, if the mode of the fragment 
marking is activated (  button of the toolbar should be pressed). The mode of the 
fragment marking can be enabled or disabled in Image -> Select Fragment menu 
command or with the help of   button of the Application toolbar. 
 
Parameters of the marked fragment are displayed in Info tab of Image Properties dialog 
panel. 
 
It is possible to change the size of the marked fragment by clicking the mouse left 
button on one of its boundaries and moving the fragment boundary to a new position 
while holding the button. One may automatically expand the fragment boundary as far 
as to the edge of the picture by double-clicking on one of the fragment boundaries.   
 
The boundaries of the marked fragment can be exactly established manually by clicking 

 button in Fragment elements group of Info tab. It is necessary to set the position of 
the fragment boundaries in image pixels in the appeared Fragment window (Figure 10) 
and press OK button. 
 

 
 

Figure 10. 
 
If the image is converted into a cartographic projection, and the mode of the fragment 
making is turned off or another fragment is marked, the boundaries of a converted part 
of the image are marked in green.  
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# $ K 
Image Export 

 
The Application supports two modes of image export: 
 
-   In �Save Image As� mode the image is exported �as it is�, i.e. with the initial selection 

and order of bands, initial radiometric resolution and initial contrasting. Supported 
export formats are as follows: TIFF/GeoTIFF, BIL ArcInfo, ERDAS IMG, EUROMAP 
Fast Format. 

-   In �Save View As� mode the image is exported with the current view window 
parameters, i.e. with the current color synthesis (RGB) or channel selection 
(Grayscale), current contrasting and radiometric resolution of 8 bit/pixel. Supported 
export formats are as follows: TIFF/GeoTIFF, ERDAS IMG, BMP, PGM/PPM. 

 
In both above mentioned modes the image is exported completely, if the mode of 
fragment marking is disable; and the current fragment is exported, if the mode of 
fragment marking is enabled. 
 
In both above mentioned modes, while exporting mapped image additional files are 
created in an exported format, besides the image itself: ESRI WORLD file and SCANEX 
PROJ file with parameters of a map projection. They further make it possible to open up 
images by many GIS software (ArcInfo, ENVI, ERMapper, ERDAS IMAGINE etc.). 
 
The image or its marked fragment can be exported in �Save Image As� mode by File -> 
Save Image As…menu command or by clicking   button on the Application toolbar. It 
is necessary to select file name and select a recording format in the appeared dialog 
box for file saving (Figure 11). Image export in �Save View As� mode is made similarly 
through File -> Save View As… menu command. 
 

 
 

Figure 11. 
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The Application provides for the export of geographic grid in HDF file. For this it is 
necessary to select �GEOGRID (*.gg.hdf)� format in the Save As dialog box and to 
press Save button. Further it is necessary to set step of grid in pixels and to press the 
OK button in the appeared Geographical grid parameters dialog box (Figure 12). 
 

 
 

Figure 12. 
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# $ K 
Printing 
 
The Application provides for the following: 
 
-   printer parameters setting; 
-   page parameters setting; 
-   page header and footer setting; 
-   preview of the printed page; 
-   printing the whole image or a marked fragment. 
 
Use File -> Print Setup… menu command to call a dialog box of printing parameters 
setting (Figure 13). 

 

 
 

Figure 13. 
 
Use File -> Page Setup… menu command to call a dialog box of page parameters 
setting (Figure 14). 
 
To set page header and footer it is necessary to use File -> Header & Footer… menu 
command and to enter the text lines in the appeared dialog box (Figure 15). 
 
Use File -> Print Preview menu command or   button of the Application toolbar for 
preview of a page being printed. It is important to remember, that during preview the 
image itself is displayed in a compressed form for fast redrawing (coarsened view of a 
bigger image in no way have an impact on the further printing quality). 
 
Use File -> Print… menu command or  button of the Application toolbar to open a 
standard printing dialog box. 
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Figure 14. 
 
 

 
 

Figure 15. 



 ScanMagic v.1.4.4  

 Copyright © 2002 RDC ScanEx Page 30 of 30  
 

 
                                                 
# ID_FILE_1 
$ File1 
K Application Purpose 
# ID_FILE_2 
$ File2 
K Requirements to Hardware 
# ID_FILE_3 
$ File3 
K Application Composition 
# ID_FILE_4 
$ File4 
K Image Import 
# ID_FILE_5 
$ File5 
K Obtaining Information about Image 
# ID_FILE_6 
$ File6 
K Image View Control 
# ID_FILE_7 
$ File7 
K Image Geographical Location 
# ID_FILE_8 
$ File8 
K Operation with Vector Maps 
# ID_FILE_9 
$ File9 
K Conversion to Cartographic Projections 
# ID_FILE_10 
$ File10 
K Operation with Image Fragments 
# ID_FILE_11 
$ File11 
K Image export 
# ID_FILE_12 
$ File12 
K Printing 


	ScanMagic
	Application Purpose
	Requirements to Hardware
	Application Composition
	Image Import
	Obtaining Information about Image
	Image View Control
	Image Geographical Location
	Operation with Vector Maps
	Conversion to Cartographic Projections
	Operation with Image Fragments
	Image Export
	Printing


